sakamttyの日記

天文、宇宙、子育て(一児の父)、本・絵本について書いてます。

scipy モジュールのインストール(OS: Vine Linux 6.3)

○準備

scipy のインストールの前に

numpy をインストール。

apt-get install numpy

pip install numpy --upgrade

 

○本番

pip install scipy

とすると、lapackがないとエラーメッセージ。

apt-get install lapack
apt-get install lapack-devel

必要ないかもしれませんが、以下も実行。

apt-get install python27-devel
apt-get install libevent-devel
apt-get install gcc3-g77pip install scipy

とすると、

 *The following required packages can not be built

*freetype,png,png

とエラーメッセージ。

apt-get install libpng10

apt-get install libpng

apt-get install freetype2-devel

apt-get install qhull
apt-get install qhull-devel

apt-get install python-tornado

apt-get install agg
apt-get install agg-devel

*pycxxがないとエラーメッセージ
http://sourceforge.net/projects/cxx/

からダウンロードし、

python setup.py build
python setup.py install

再び

pip install scipy

無事インストール完了。

 

 

★☆★☆★☆ ナウでヤングなレンタルサーバー!ロリポップ! ☆★☆★☆★
月額100円(税抜)~容量最大400GB!大人気のWordpressも簡単インストール★

 

100GB、マルチドメインやMySQLが無制限。CGI・PHP高速化機能搭載【X2】

 

 

 

人気ブログランキングへ

にほんブログ村 科学ブログへ
にほんブログ村